THREAD: [JailbreakME Webkit!] Remote Code Execution 4.0X WebKit Exploit! (Updated 3/30/17)
  1. 03-29-2017, 07:27 PM
    Hydrogen's Avatar
    Hydrogen
    Super Mod
    Hydrogen's Avatar
    Hydrogen
    Super Mod
    5,392
    Posts
    92,510
    Reputation
    Aug 2015
    NextGenUpdate
    You must login or register to view this content.


    So previously, we had seen You must login or register to view this content. had been lurking around on the PS4 Scene for a bit due to the iOS being somewhat similar to things which of course, ended up not working. He stated that he was actually resigning from the iOS Jailbreak which is really sad to see because he was a really intelligent individual in that specific field. Qwerty had tweeted out a link which we leads us to a RCE 4.0X WebKit Exploit.



    Link to WebKit: [url=rce.party/ps4/]JailbreakME RCE 4.0X WebKit[/url]



    He did say this does not work on 4.50 since Sony had accidentally patched up a bunch of exploits by switching WebKits Branches. So, if you're on 4.50, you're out of luck. Since this is better than 1.76 and 3.55, we might have a great thing here, so better go ahead and buy a new PS4, or stay below 4.50. This actually works on any firmware below 4.50, but if it is stable, this will be an amazing new thing besides the 1.76/3.55.

    Good luck out there! Credits to WWC for the image!







    Last edited by Hydrogen ; 03-30-2017 at 11:02 PM.

  2. The Following 3 Users Say Thank You to Hydrogen For This Useful Post:

    , ,

  3. 03-30-2017, 11:23 AM
    22
    Posts
    10
    Reputation
    Jun 2016
    NextGenUpdate
    Originally Posted by EYE View Post
    Isn't this patched?


    it was patched on later 4.50 from what i heard!
  4. 03-30-2017, 12:07 PM
    Sparrow's Avatar
    Sparrow
    Big Papi
    Sparrow's Avatar
    Sparrow
    Big Papi
    1,098
    Posts
    7,833
    Reputation
    Nov 2016
    NextGenUpdate
    Originally Posted by Hydrogen View Post
    He did say this does not work on 4.50 since Sony had patched up the vulnerability version, so if you're on 4.50, you're out of luck.


    Originally Posted by EYE View Post
    Isn't this patched?


    Needa
  5. 03-30-2017, 12:42 PM
    Hydrogen's Avatar
    Hydrogen
    Super Mod
    Hydrogen's Avatar
    Hydrogen
    Super Mod
    5,392
    Posts
    92,510
    Reputation
    Aug 2015
    NextGenUpdate
    Originally Posted by Sparrow View Post
    Wait so this is good for original, slim & pro versions?

    Ps. Nice share Happy



    Not really useful yet, but should be in the future *fingers crossed* - if you can I'd go with the 1.76, can always update if something comes from 4.xx


    Not true, it is useful. On Twitter, some of my buddies have been checking which firmwares work or not. Slims worked I think on 3.15/3.50/3.55. Any of those, but no idea on the PRO.

    Firmwares below 2.00 didn't do anything or the vulnerability failed.

    Originally Posted by EYE View Post
    Isn't this patched?


    Sony knew about things so they quickly patched mostly everything on 4.50 including the WebKit with some a ton of 1.76 exploits strategies that could of worked for 4.50. That's why this is good if stable for the firmwares below 4.50 which actually is better than 1.76/3.55.
    Last edited by Hydrogen ; 03-30-2017 at 01:33 PM.

  6. 03-30-2017, 12:47 PM
    DMaRUAE's Avatar
    DMaRUAE
    Bounty hunter
    DMaRUAE's Avatar
    DMaRUAE
    Bounty hunter
    157
    Posts
    1,473
    Reputation
    Jun 2013
    NextGenUpdate
    when the ps4 hacked 100% my first game i will found offset (bloodborn) and (dark soul iii ) Kas
  7. 03-30-2017, 12:53 PM
    Black Panther's Avatar
    Black Panther
    Former Staff
    Black Panther's Avatar
    Black Panther
    Former Staff
    384
    Posts
    39,539
    Reputation
    Feb 2012
    NextGenUpdate
    Originally Posted by lubu1 View Post
    I'm really confused right now gave me your opinions guys
    Buying 1.76 ps4 ?
    Buying 4.xx ps4 ?


    Why not both like me Kappa
  8. The Following User Thanked Black Panther For This Useful Post:


  9. 03-30-2017, 12:57 PM
    Hydrogen's Avatar
    Hydrogen
    Super Mod
    Hydrogen's Avatar
    Hydrogen
    Super Mod
    5,392
    Posts
    92,510
    Reputation
    Aug 2015
    NextGenUpdate
    Originally Posted by Black View Post
    Why not both like me Kappa


    Oh you're rich Kappa.. pass some around then :troll:
  10. 03-30-2017, 01:16 PM
    Hydrogen's Avatar
    Hydrogen
    Super Mod
    Hydrogen's Avatar
    Hydrogen
    Super Mod
    5,392
    Posts
    92,510
    Reputation
    Aug 2015
    NextGenUpdate
    Added in some new Tweets in the thread for further information and analysis.
  11. 03-30-2017, 09:02 PM
    Hydrogen's Avatar
    Hydrogen
    Super Mod
    Hydrogen's Avatar
    Hydrogen
    Super Mod
    5,392
    Posts
    92,510
    Reputation
    Aug 2015
    NextGenUpdate
    fcall / syscall primitives have now been added. He also shared a new working picture from Twitter to confirm it! New tweets at the top.
  12. 03-30-2017, 11:02 PM
    Hydrogen's Avatar
    Hydrogen
    Super Mod
    Hydrogen's Avatar
    Hydrogen
    Super Mod
    5,392
    Posts
    92,510
    Reputation
    Aug 2015
    NextGenUpdate
    New tweet added: You must login or register to view this content.